پایگاه خبری ارتباطات و فناوری اطلاعات

آخرین اخبار دنیای ارتباطات و فناوری اطلاعات

آسیب پذیری در Apache Tomcat با شدت بالا

آسیب پذیری در Apache Tomcat

آسیب پذیری در Apache Tomcat

این مطلب را در شبکه های اجتماعی خود به اشتراک بگذارید
زمان مطالعه: < 1 دقیقه

کشف آسیب‌پذیری در Apache Tomcat

آسیب پذیری در Apache Tomcat با شدت بالا شناسایی شد. این آسیب پذیری به‌دلیل اعتبارسنجی نامناسب در ورودی، امکان Request Smuggling (قاچاق درخواست) در reverse proxy را برای مهاجم فراهم می‌آورد.

سرویس اخبار امنیت – یک آسیب‌پذیری با شناسه CVE-2023-46589 و شدت بالا در  Apache Tomcatشناسایی شده است به‌دلیل اعتبارسنجی نامناسب در ورودی، امکان Request Smuggling (قاچاق درخواست) در reverse proxy را برای مهاجم فراهم می‌آورد.
به گزارش خبر ICT از ایستنا این آسیب‌پذیری به این ‌دلیل رخ می‌دهد که Tomcat، HTTP trailer headers را به درستی تجزیه و تحلیل نمی‌کند. یک trailer header ویژه که از اندازه header فراتر می‌رود، می‌تواند منجر به در نظر گرفتن یک درخواست به‌عنوان درخواست‌های متعدد توسط Tomcat شود که در نتیجه در reverse proxy، امکان Request Smuggling رخ خواهد داد. محصول به عنوان یک عامل HTTP واسطه (مانند یک پروکسی یا فایروال) در جریان داده بین دو بخش مانند یک کلاینت و سرور عمل می‌کند، اما درخواست‌ها یا پاسخ‌های HTTP نادرست را به روش‌هایی که با نحوه پردازش پیام‌ها توسط نهادهایی که در مقصد نهایی هستند، سازگار باشد، تفسیر نمی‌کند. در واقع درخواست در سمت کلاینت و سرور بصورت ناهمگان تفسیر می‌شود.

 محصولات تحت تأثیر

این آسیب‌پذیری محصول Apache Tomcat.Tomcat نسخه‌های 11.0.0-M1 تا 11.0.0-M10، 10.1.0-M1 تا 10.1.15، 9.0.0-M1 تا 9.0.82 و 8.5.0 تا 8.5.95 را تحت تأثیر قرار می‌دهد.

توصیه‌های امنیتی
توصیه می‌شود کاربران در اسرع وقت نسبت به ارتقاء Apache Tomcat.Tomcat به نسخه‌های زیر اقدام نمایند:

✅ بیشتر بخوانیم 👈👈👈  تشخیص پارکینسون به کمک هوش مصنوعی

1- Apache Tomcat نسخه 11.0.0-M11یا جدیدتر
2- Apache Tomcat نسخه 10.1.16 یا جدیدتر
3- Apache Tomcat نسخه 9.0.83 یا جدیدتر
4- Apache Tomcat نسخه 8.5.96 یا جدیدتر

About The Author

آخرین خبرها